lyx file from 2015 not converted to pdf

Wolfgang Engelmann engelmann at
Tue Mar 24 18:24:38 UTC 2020

Am 24.03.20 um 19:21 schrieb Wolfgang Engelmann:
> Am 24.03.20 um 19:08 schrieb Pavel Sanda:
>> On Fri, Mar 20, 2020 at 09:43:00AM +0100, Wolfgang Engelmann wrote:
>>> Thanks all for suggestions.
>>> The file did compile in 2015.
>>> I tried to remove parts of the original.
>>> It turned out that a nomenclature lead to the error
>> As we figured out in background, the problem is using ligature 'fl'
>> as one character instead of normally using two characters. Replacing
>> them fixes the problem.
>> Attached is minimal example.
>> I was not capable to have lyx segfault because of it.
>> Question, I guess either for Juergen or Guenter, is whether
>> we should know unicode inside nomenclature and should be fixing
>> this issue or this kind of use should not be supported.
>>  From the users point of view we don't report any useful error.
>> Pavel
> Pavel, I ran your mwe-lyx and got
> LyX: Software exception Detected
> LyX has caught an exception, it will now attempt to save all unsaved 
> documents and exit.
> Exception: std::exception
> Did I understand you correctly, that you did not receive this message?
> I am using Debian bullseye and Lyx 2.3.3
> Should I upgrade to 2.3.4?
> Wolfgang

I am sorry, I just see that I use lyx version

More information about the lyx-users mailing list