LyX not compiling any more for Beamer and modernCV classes (missing beginDocument, missing Glyphs)

Dr Eberhard Lisse nospam at lisse.NA
Mon Nov 25 21:36:08 UTC 2019

Try this:

Document -> Settings > Local Layout


	PackageOptions fontspec no-math
	Requires fontspec


and let us know if it works :-)-O


On 2019-11-25 18:43 , Daniel Gómez Martínez wrote:
> Thank you, moving the folder with my .lyx file to a path without ASCII
> characters only solved my issue, now I know I only need to wait until the
> dev team release a new version with this solved. For now I'll just compile
> my LyX files in reduced paths.
> Again, thank you very much!
> *Daniel Gómez Martínez | Profesional en ingeniería eléctrica*
> El lun., 25 nov. 2019 a las 11:40, Jürgen Spitzmüller (<spitz at>)
> escribió:
>> Am Montag, den 25.11.2019, 11:22 -0500 schrieb Daniel Gómez Martínez:
>>> Hello everyone; I'm using Debian and LyX 2.3.3.
>>> Some time ago I made some presentations with Beamer and my CV with
>>> modercv class in LyX. LyX used to work just fine with those classes
>>> (although I think those were working with LyX 2.3.2), but suddenly,
>>> things stopped working. According to log file, it has something to do
>>> with the fonts, but I've found no information online to help solve my
>>> problem, I don't really know what package/config I'm missing now.
>>> Any help to solve this issue would be greatly appreciated, hereafter
>>> are the contents of my log file while compiling the Beamer LyX file
>>> found at "Help -> Specific Manuals -> Beamer", so you can see that
>>> not even the default Beamer file is compiling for me (I had to save
>>> that beamer.lyx somewhere else for LyX to actually try to compile it,
>>> as it seems the default beamer.lyx comes pre-compiled).
>> I think this has to do with a recent LaTeX update that changes the
>> handling of path names with non-ASCII characters and spaces. See
>> I suppose the documents are in a path that consists of such characters
>> (maybe your surname?). Does the error go away if you move the document
>> to a patch with ASCII characters only?
>> Jürgen
>> PS. We have a fix for this in the development version, but it is not
>> tested thoroughly yet.

More information about the lyx-users mailing list