Why does lyx add: '\noindent' when generating my .tex file

Paul A. Rubin parubin73 at gmail.com
Sat Nov 16 21:00:48 UTC 2019

On 11/15/19 7:09 PM, Ralph Boland wrote:
> I am using Debian 10  and Lyx  2.3.2.
> In my thesis (2002) I used the algolyx package and it worked fine in 2002.
> But I have been updating my thesis to fix a few things (a bad idea i
> know) and in the updated
> version most of my algorithms printed properly but a few failed for
> reasons I do not
> understand.  I seems like a Lyx or Latex error due to using upgraded
> Lyx/Latex software
> since I haven't changed the lyx code or latex code (not necessarily
> true of course but not the issue here anyway).
> Rather than track this issue down I decided to use the enumitem
> package and rewrite the
> algorithms that  Lyx/Latex could no longer handle.
> Unfortunately, this also failed because of what appeared to be a bug
> in the enumitem package.
> So I emailed the enumitem package maintainer with a sample piece of
> latex code generated by Lyx demonstrating the bug.  (Lesson learned:
> Do not use Lyx to generate latex code demonstrating a bug in Latex.)
> Anyway the maintainer determined that there was a '\noindent'  in the
> latex code that
> shouldn't be there and removing it solved the problem.  So the problem is not a
> enumitem package bug!
> Alas, I do not know why Lyx added the  '\noindent' code.  I did not
> tell it to do so and so
> now I (foolishly?) assume I have found a Lyx bug!
> Can anyone tell me if this is a Lyx bug and if not then how do I get
> Lyx to not add the
> 'offending \noindent' code?
> I have attached the problematic Lyx file and the pdflatex tex file
> generated from it containing
> the 'noindent' code.
> While I'm here i'd like to point out that when I run Lyx on this file
> (and most other Lyx files)
> I get the message:
>                             'step: Counter does not exist: enum'  many times.
> If anyone can shed light on why I get this message that would me most helpful.
> Thanks for any help received.
> Ralph Boland  rpboland at gmail.com
Curious. First, when I compile your LyX file here (LyX 2.3.3, Linux Mint 
18.3) without making any changes to it, I do not see an error with level 
3 indentation. The "junk" entry in the AlgNum2 list aligns with the 
"deeper junk" entry in the AlgNum list. The deeper entries in AlgNum2 
also align with antecedents one level shallower in AlgNum. FWIW, I'm 
compiling with pdflatex. The compiled PDF file is attached.

Second, I do see a problem with indentation of the line "does this line 
also ...", and it is caused by a \noindent inserted immediately prior to 
the "if" from "if c = d". I don't think that \noindent is being inserted 
by LyX, at least not automatically. I retyped your document (without the 
notes and other baggage) and did not get the errant \noindent in my 
version (also attached). That leads me to wonder if some combination of 
typing stuff in and editing it somehow introduced the \noindent.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20191116/79078c73/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: enumItemBug.pdf
Type: application/pdf
Size: 23692 bytes
Desc: not available
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20191116/79078c73/attachment-0001.pdf>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: newfile1.lyx
Type: application/x-lyx
Size: 5097 bytes
Desc: not available
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20191116/79078c73/attachment-0001.lyx>

More information about the lyx-users mailing list