Why does lyx add: '\noindent' when generating my .tex file

Ralph Boland rpboland at gmail.com
Sat Nov 16 00:09:33 UTC 2019

I am using Debian 10  and Lyx  2.3.2.
In my thesis (2002) I used the algolyx package and it worked fine in 2002.
But I have been updating my thesis to fix a few things (a bad idea i
know) and in the updated
version most of my algorithms printed properly but a few failed for
reasons I do not
understand.  I seems like a Lyx or Latex error due to using upgraded
Lyx/Latex software
since I haven't changed the lyx code or latex code (not necessarily
true of course but not the issue here anyway).

Rather than track this issue down I decided to use the enumitem
package and rewrite the
algorithms that  Lyx/Latex could no longer handle.

Unfortunately, this also failed because of what appeared to be a bug
in the enumitem package.
So I emailed the enumitem package maintainer with a sample piece of
latex code generated by Lyx demonstrating the bug.  (Lesson learned:
Do not use Lyx to generate latex code demonstrating a bug in Latex.)

Anyway the maintainer determined that there was a '\noindent'  in the
latex code that
shouldn't be there and removing it solved the problem.  So the problem is not a
enumitem package bug!

Alas, I do not know why Lyx added the  '\noindent' code.  I did not
tell it to do so and so
now I (foolishly?) assume I have found a Lyx bug!

Can anyone tell me if this is a Lyx bug and if not then how do I get
Lyx to not add the
'offending \noindent' code?
I have attached the problematic Lyx file and the pdflatex tex file
generated from it containing
the 'noindent' code.

While I'm here i'd like to point out that when I run Lyx on this file
(and most other Lyx files)
I get the message:
                           'step: Counter does not exist: enum'  many times.
If anyone can shed light on why I get this message that would me most helpful.

Thanks for any help received.

Ralph Boland  rpboland at gmail.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: enumItemBug.lyx
Type: application/x-lyx
Size: 6239 bytes
Desc: not available
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20191115/7a3cb42a/attachment.lyx>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: enumItemBug.tex
Type: text/x-tex
Size: 2826 bytes
Desc: not available
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20191115/7a3cb42a/attachment.tex>

More information about the lyx-users mailing list