Reuse MikTeX from Win10 in WSL

Cris Fuhrman fuhrmanator at
Wed Oct 23 14:20:18 UTC 2019

Posting a status of what I tried:

I followed to install MiKTeX
for Ubuntu (under WSL).

I managed to get MiKTeX installed in WSL (with the "shared" option, and
using the common-X options described at to see the packages
installed already in Windows (miktex-console sees them in the list, I
didn't need to download them again).

However, I had to delete the filename databases, whose process is described

Sadly, I could not get MiKTeX console to run in Admin mode (this may be a
problem with WSL). Whenever I tried (even with sudo to launch the console),
the program just exits and I saw no errors that were obvious. Also, LyX
wasn't finding biber correctly, which turned out to be a symbolic link
issue in MiKTeX.

I had posted an issue on the MiKTeX github and got a quick response that
solved the above problems.

Conclusion for today: It's working on my current system, for a complex
document that uses biblatex and lots of packages (not a complete test, but
encouraging nonetheless). I will delete my redundant TexLive install in WSL
to save the gigs of SSD.

On Fri, Oct 18, 2019 at 5:54 AM Kees Zeelenberg (kzStats) <
kzstatis at> wrote:

> Thanks for sharing - this is interesting. Did you turn off the option on
> the Linux side to install automatically missing modules (assuming that such
> an option exists there, too)? One of the nice things about MikTeX in
> Windows is that the modules are loaded dynamically inside of LaTeX (or even
> LyX). TeXLive has huge "chunks" for modules (via apt-get), at least as
> far as I can tell.
> If you turn it on, then missing packages might be installed twice. I am
> not sure if you can configure MikTeX such that packages are installed in
> the common package directory (if I remember correctly, you cannot move it
> up above the Linux root directories in the MixTeX console).  If you turn it
> off, then you must either install the packages by hand or switch to
> Windows, which may not be such a problem when using WSL. You might also try
> to add the Linux package directory to the list of root directories under
> Windows; I haven’t tried this but perhaps it works.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list