Compile Problems After Updating to Qt6

Christoph Schmitz chr.schmitz at
Thu Mar 11 09:52:04 UTC 2021

After homebrew silently updated Qt to v6 I cannot compile LyX anymore. Where is the right place to ask questions regarding build issues?

If this is the right place, here is my questions:


Operating system: macOS 11.3 Beta (20E5196f)

I have been struggling with this problem for a few days now. Last week my homebrew installation quietly updated Qt to v6 (brew upgrade). Since then I can't compile LyX anymore. Unfortunately I learned about the "brew pin" command too late.

When running .\configure I get the error message: "configure: error: cannot compile a simple Qt executable. Check you have the right $QTDIR."

I tried to set $QTDIR to the following directories:

/usr/local/opt/qt at 6

I also tried to downgrade to Qt5, but this also did not solve the problem. I have noticed that Qt5 is not installed in the folder "qt" anymore (this is now the place, where Qt6 is installed), but in a folder with the name "qt at 5".

I also deleted my local repository and started from scratch. Also no success.

I appreciate any recommendation what to do.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list