Failure bilding

Scott Kostyshak skostysh at
Sat Feb 20 03:01:20 UTC 2021

On Fri, Feb 19, 2021 at 05:09:59PM -0800, Rich Shepard wrote:
> On Fri, 19 Feb 2021, Scott Kostyshak wrote:
> > Just to try something different, do you feel like trying the cmake build?
> > Let us know if you want instructions for how to use cmake.
> Scott,
> I can try that. Since I switched from Red Hat-7 to Slackware-8.0 in 2003
> I've built Lyx using the SlackBuild script (copy attached.) And it's always
> worked flawlessly for me ... until earlier this week when I inadvertently
> removed all the SBo packages while upgrading the distribution (and spent the
> rest of the week re-building and re-installing them).
> I should mention that the SlackBuild script worked fine last month in the
> upgrade from 2.6.3 to That's why I'm puzzled it now fails. Same
> Qt4 and Qt5/PyQt5 versions as then.
> And long ago I switched from writing tools for me in C to Python so I'm 20
> years out of data on all the different C/C++ compilers now out there.
> Carpe weekend,
> Rich

Makes sense, Rich. I was just thinking it might provide a clue as to
what's going on with the other build. Sometimes different build systems
give different errors. Similar to C++: if I don't understand an error
from GCC, sometimes I compile with Clang.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
URL: <>

More information about the lyx-users mailing list