Fwd: no accents with dead keys (SOLVED)

jorge hernando jorgea.hernando at gmail.com
Wed Nov 11 16:11:18 UTC 2020

I forgot to include lyx-users, here it goes the mail
---------- Forwarded message ---------
From: jorge hernando <jorgea.hernando at gmail.com>
Date: Wed, Nov 11, 2020 at 1:05 PM
Subject: Re: no accents with dead keys (SOLVED)
To: José Abílio Matos <jamatos at lyx.org>

Hi Jose

 I searched old e-mails and I believe I can confirm it's a bug in qt5 that
ts triggered by un unknown mechanism. The previous fedora version I had
(the 29) had lyx 2.3.3 and qt5.11 and it worked perfectly. When I installed
fedora 32 the deadkeys were effectively dead. However, with featherpad (a
qt application) I had the same problem while with nedit (non a qt appl.)
had all the dead keys in order. I also think that not all the installations
have the same problem because if it all had it, there probably were a
massive outcry: almost every language, except english, has accents.

Lastly, I have not the foggiest notion of what Input Methods are; please
tell me if there is something I can do.



On Wed, Nov 11, 2020 at 12:15 PM José Abílio Matos <jamatos at lyx.org> wrote:

> Hi Jorge,
>   let us keep this discussion in the mailing list to help others that
> could have the same problem. :-)
> On Wednesday, November 11, 2020 1:20:37 PM WET jorge hernando wrote:
> > I use mate as a desktop.
> I use mainly kde, sometimes test in gnome, and although I have not mate
> installed but I can install it to see if I can reproduce the problem.
> > This is the first time I had problems with lyx, and I'm using it from the
> > very beginning, I think more than twenty years. The previous Fedora I
> had,
> > was  29, I don't remember the qt version but I remember that it worked
> > flawlessly. I'm sure that the bug is in the qt5 library, but I don't know
> > how to discover how it is triggered. Any suggestions?
> One of the first things to test is to see if this is a problem of lyx or
> if you see it in other qt5 based applications. Simple examples here are
> kate and kwrite but any other application based on qt5 is OK to test. Could
> you try please and see if the problem also happens there?
> My first guess would be that this is related with Input Methods:
> https://fedoraproject.org/wiki/I18N/InputMethods#Qt_IM_modules
> but only testing can we know. :-)
> > Regards
> >
> > Jorge
> --
> José Abílio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20201111/0188aa9b/attachment-0001.html>

More information about the lyx-users mailing list