no accents with dead keys (SOLVED)

jorge hernando jorgea.hernando at
Tue Nov 10 19:03:42 UTC 2020

Some time ago I begun a thread about dead keys not working in lyx that
ended up with a quite cumbersome and imperfect solution (it didn't work in
formulas and was an unmitigated problem in tables); i.e. to write in a non
qt-editor and then paste the text. However, a couple of days ago, Flavio
Eler de Melo told me in an e-mail the solution. He has the pc under Ubuntu
18.04 which provides both Qt5 and Qt4. He removed qt5 and compiled lyx
(even the latest 2.4.0) with Qt4 and the dead keys worked.

I'm in fedora 32 and didn't want anything drastic so I downloaded qt4lib
and the lyx sources and run configure with the line

./configure --with-qt-dir=/usr/share/qt4 --with-extra-lib=/usr/lib64

and ended up with the executable lyx-  in /usr/local/bin which runs
with Qt4 (the dead keys work perfectly) which coexists with the executable
(just in case) lyx which runs with Qt5.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list