LyX 2.3.5

Bernt Lie Bernt.Lie at
Wed Jun 10 10:05:48 UTC 2020

Hm… here is what I did:

  1.  I first installed MikTeX to the default path that it suggested, and used my private path for LyX. No success.
  2.  Next, I deleted LyX, and tried to re-install it to the default path. But the default path never showed up; no matter whether I deleted every file related to LyX, it still stuck to the original path that I had defined.
  3.  I then entered “regedit”. I deleted every mention of LyX in various forms from “regedit”.
  4.  Next, I tried to reinstall LyX. Now it suggested a default path. I installed LyX to this default path.
  5.  Now, it seems to work.

In summary: LyX doesn’t properly clean up the registry when I uninstall it.

Another observation…

  *   Before I deleted the registry elements and installed LyX to my private directory, installation of LyX took some one hour or something.
  *   After I deleted elements from “regedit”, the installation took a couple of minutes.


From: Kees Zeelenberg (kzStats) <kzstatis at>
Sent: Wednesday, June 10, 2020 11:12
To: Bernt Lie <Bernt.Lie at>; parubin73 at; lyx-users at
Subject: RE: LyX 2.3.5

Van: lyx-users <lyx-users-bounces at<mailto:lyx-users-bounces at>> Namens Bernt Lie
Verzonden: woensdag 10 juni 2020 09:58
Aan: parubin73 at<mailto:parubin73 at>; lyx-users at<mailto:lyx-users at>
Onderwerp: RE: LyX 2.3.5

So… I have uninstalled both MikTeX and LyX, and try to re-install them.

With MikTeX, I do the following:

  1.  Choose to install it under directory “C:\\Program_Files\MikTeX\MikTeX_2_9” instead of the default location (“…\AppData\Local\Programs\MikTeX 2.9\”)
  2.  Settings: Preferred paper size – A4, Install missing pagackages on-the-fly: Yes
  3.  After MikTeX has installed packages, I check for updates. There were 8 updates, which I installed from “A random package repository on the internet”.

Next, I install LyX 2.3.5:

  1.  I install LyX in directory “C:\Program_Files\LyX\LyX_2_3”
  2.  The LyX installer finds MikTeX at “C:\Program_Files\MikTeX\MikTeX_2_9\miktex\bin\x64”.

  1.  LyX takes some time to install, and downloads some missing packages:

[cid:image001.png at 01D63F1F.6D978170]

  1.  When LyX has been installed, I try to open a template. Result:

[cid:image002.png at 01D63F1F.6D978170]

I do a search for file IEEEtran.cls, and it is there:
[cid:image003.png at 01D63F1F.6D978170]


  1.  Why doesn’t LyX find this file?
  2.  Is the problem that I have not chosen the default installation path of LyX and/or MikTeX?

I just had the same error earlier this morning. From my experience:

  1.  Probably because the filename database has not been updated. This may happen when you install MikTeX as an administrator (user who has administrative rights), but call LyX as that same user but without invoking his administrative rights; or if you have followed some variant of this.
In general, it is best to install as an administrator but call your applications as an ordinary user (i.e. user without any administrative rights), and so keep a strict difference between the two types of users.
  2.  Perhaps. You might try it if you cannot follow the advice under A.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 17526 bytes
Desc: image001.png
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 10043 bytes
Desc: image002.png
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.png
Type: image/png
Size: 8780 bytes
Desc: image003.png
URL: <>

More information about the lyx-users mailing list