LyX 2.3.5

Bernt Lie Bernt.Lie at
Wed Jun 10 07:58:11 UTC 2020

So… I have uninstalled both MikTeX and LyX, and try to re-install them.

With MikTeX, I do the following:

  1.  Choose to install it under directory “C:\\Program_Files\MikTeX\MikTeX_2_9” instead of the default location (“…\AppData\Local\Programs\MikTeX 2.9\”)
  2.  Settings: Preferred paper size – A4, Install missing pagackages on-the-fly: Yes
  3.  After MikTeX has installed packages, I check for updates. There were 8 updates, which I installed from “A random package repository on the internet”.

Next, I install LyX 2.3.5:

  1.  I install LyX in directory “C:\Program_Files\LyX\LyX_2_3”
  2.  The LyX installer finds MikTeX at “C:\Program_Files\MikTeX\MikTeX_2_9\miktex\bin\x64”.

  1.  LyX takes some time to install, and downloads some missing packages:

[cid:image002.png at 01D63F08.59DF8F40]

  1.  When LyX has been installed, I try to open a template. Result:

[cid:image003.png at 01D63F0C.2F248BD0]

I do a search for file IEEEtran.cls, and it is there:
[cid:image004.png at 01D63F0D.8FA7C570]


  1.  Why doesn’t LyX find this file?
  2.  Is the problem that I have not chosen the default installation path of LyX and/or MikTeX?


From: lyx-users <lyx-users-bounces at> On Behalf Of Paul A. Rubin
Sent: Tuesday, June 9, 2020 5:50 PM
To: lyx-users at
Subject: Re: LyX 2.3.5

On 6/9/20 11:15 AM, Bernt Lie wrote:

I installed LyX 2.3.5 a couple of days ago (?), and it worked fine. (Windows 10 64bit, latest version.)

Today, one of my students tried to install some template for LyX 2.3.5, and messed around with MikTeX. But in the end that didn't work. So in the end, I uninstalled MikTeX, Inkscape, and LyX, and re-installed the programs.

Now I get this error message:

[cid:image001.png at 01D63F01.641F5320]»

When I try to open a template.

  *   What has gone wrong? Why is “extarticle.cls” missing?
  *   How can I fix it?


Oops! I inadvertently replied to Bernt offline, suggesting that the extsizes package had not been installed. Pasting in his reply:

did nothing special to include specific packages a couple of days ago, and nothing special today.
It's been quite a while since I used MikTeX, but I vaguely recall that installation options included a modest size package with common classes and something of an omnibus installation with all sorts of packages (and a large footprint). Bernt, is it possible that you did a full installation in the case that the document class was available and a smaller installation in the case where it was not?

I'm assuming here that basic classes (such as article.cls) remain available even when extarticle.cls does not.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 12044 bytes
Desc: image001.png
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 17526 bytes
Desc: image002.png
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.png
Type: image/png
Size: 10043 bytes
Desc: image003.png
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image004.png
Type: image/png
Size: 8780 bytes
Desc: image004.png
URL: <>

More information about the lyx-users mailing list