LyX 2.3.5

Bernt Lie Bernt.Lie at
Tue Jun 9 16:10:58 UTC 2020

From: lyx-users <lyx-users-bounces at> On Behalf Of Bernt Lie
Sent: Tuesday, June 9, 2020 6:05 PM
To: parubin73 at; lyx-users at
Subject: RE: LyX 2.3.5

From: lyx-users <lyx-users-bounces at<mailto:lyx-users-bounces at>> On Behalf Of Paul A. Rubin
Sent: Tuesday, June 9, 2020 5:50 PM
To: lyx-users at<mailto:lyx-users at>
Subject: Re: LyX 2.3.5

On 6/9/20 11:15 AM, Bernt Lie wrote:

I installed LyX 2.3.5 a couple of days ago (?), and it worked fine. (Windows 10 64bit, latest version.)

Today, one of my students tried to install some template for LyX 2.3.5, and messed around with MikTeX. But in the end that didn't work. So in the end, I uninstalled MikTeX, Inkscape, and LyX, and re-installed the programs.

Now I get this error message:

[cid:image001.png at 01D63E89.4CDF69C0]

When I try to open a template.

  *   What has gone wrong? Why is “extarticle.cls” missing?
  *   How can I fix it?


Oops! I inadvertently replied to Bernt offline, suggesting that the extsizes package had not been installed. Pasting in his reply:

did nothing special to include specific packages a couple of days ago, and nothing special today.
It's been quite a while since I used MikTeX, but I vaguely recall that installation options included a modest size package with common classes and something of an omnibus installation with all sorts of packages (and a large footprint). Bernt, is it possible that you did a full installation in the case that the document class was available and a smaller installation in the case where it was not?

I'm assuming here that basic classes (such as article.cls) remain available even when extarticle.cls does not.


The error message came up when I used the... I think it was the IEEE article style (I left office; I’ll recheck tomorrow morning). The document opened in LyX, but when I tried to preview it in Acrobat Reader, I got an error message that it could not produce the pdf file.

I’ll recheck whether I can install the “entire system” – perhaps that’s what I did... don’t recall all the questions off hand.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 12044 bytes
Desc: image001.png
URL: <>

More information about the lyx-users mailing list