no accents with dead keys

Paul A. Rubin parubin73 at
Sun Jul 12 22:54:46 UTC 2020

On 7/12/20 4:02 PM, jorge hernando wrote:
> Hallo
>   I have one PC with english keyboard (US international with dead 
> keys) and another one with spanish keyboard (Castilian Spanish with 
> dead keys) both with fedora 32 (since a couple of days) and lyx 
> In both PC have the same problem: the accents work perfectly 
> (e.g. á is " 'a ") when in a terminal, opening nedit, ooffice, etc. 
> but in lyx not only it doesn't work, the dead key is really dead: if I 
> type ' in lyx it doesn't type anything but, there is at least one 
> exception, when saving a file, I can type a name with accents (?)
>   A couple of days ago, I updated the PCs which both were with fedora 
> 29 and lyx 2.3.3 and  worked correctly. I tried downgrading lyx to 
> 2.3.4 to no avail. I wanted to install the lyx 2.3.3 of fedora 29 but 
> couldn't. I tried, according to the customization manual, to add the 
> following line to the file .lyx/lyxrc.default
>   accent-circumflex  "S-^"
>   to no avail. I created the file .lyx/lyxrc with the same line and 
> with the same result. I looked at some .kmap files in 
> /usr/share/lyx/kbd, specifically at the francais.kmap, espanol.kmap 
> and the european.kmap and all of them have the acents defined. Then I 
> went to Tools -> Editing -> Keyboard/Mouse and included them in turn 
> with no change at all. I looked at /usr/share/lyx/bind and was 
> completely lost; I didn't understand a thing. Searching with google I 
> found some references but also didn't understand them. In the mailing 
> list it is mentioned (in 2019) that there is a workaround related with 
> Qt: to include in .xsessionrc the line
>   export QT_IM_MODULE=xim
>   I created the file with that line but didn't work
>   As now I'm writing in french, which needs all the dead keys 
> combinations, I exclude the use of latex writing style.
>   As conclusion: am I doing anything wrong? The other possibilities I 
> see are: either I'm a lucky guy and I found a bug in lyx or the fedora 
> 32 implementation went askew. Any suggestions?
>   Jorge Hernando
I'm not familiar with Fedora, but on Mint (and this presumably also 
works on Ubuntu) I went into the system keyboard preferences (not LyX 
preferences) and set the "compose" key (in my case to the right Alt 
key). So in any text application, the combination Alt+' a and the 
combination Alt+a ' both produce á (with Alt being the right Alt key). 
This also works in LyX.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list