Lyx and won't open old files on Mac [Almost Solved]

Niklas Huldén nhulden at
Tue Jul 7 10:29:15 UTC 2020

Den 07-07-2020 kl. 10:02, skrev Murat Yildizoglu:
> Hi Niklas,
> It seems that I cannot reproduce this problem in Mojave. I have put a 
> lye file Cloud only and, once DB has followed my order (the tag 
> changes in the Finder), I have tried to open it in Lyx and it 
> worked: no empty file but the document itself appeared in LyX.

Thanks for your effort. It has to be something in my DB installation. If 
I make a new lyx-file and save it to some dropbox-folder it will open 
nicely from LyX or by doubleclicking in Finder. But all my old LyX-files 
show up as zero bytes in listings and won't open except by clicking from 
a DB app folder. As I said I have Catalina but I suspect something odd 
in DropBox.



>> Le 7 juil. 2020 à 13:19, Niklas Huldén <nhulden at 
>> <mailto:nhulden at>> a écrit :
>> Den 07-07-2020 kl. 03:46, skrev Murat Yildizoglu:
>>>> Le 7 juil. 2020 à 05:36, Stephan Witt <st.witt at 
>>>> <mailto:st.witt at>> a écrit :
>>>> Am 06.07.2020 um 18:45 schrieb Kornel Benko <kornel at 
>>>> <mailto:kornel at>>:
>>>>> Am Mon, 6 Jul 2020 11:58:03 -0400
>>>>> schrieb "Paul A. Rubin" <parubin73 at 
>>>>> <mailto:parubin73 at>>:
>>>>>> On 7/6/20 11:37 AM, Richard Kimberly Heck wrote:
>>>>>>> On 7/6/20 4:28 AM, Niklas Huldén wrote:
>>>>>>>> Den 01-07-2020 kl. 17:53, skrev Richard Kimberly Heck:
>>>>>>>>>> On 7/1/20 6:59 AM, Niklas Huldén wrote:
>>>>>>>>>>> Hello!
>>>>>>>>>>> I installed LyX 2.3.5 in June on my MacBook Air 13 
>>>>>>>>>>> (Catalina) and
>>>>>>>>>>> noticed that I could not open files from the "Recent files" 
>>>>>>>>>>> list in
>>>>>>>>>>> the File menu. The program opened an empty document with the 
>>>>>>>>>>> name of
>>>>>>>>>>> the recent file. I could open old documents using the 
>>>>>>>>>>> "Open.." choise
>>>>>>>>>>> from the menu.
>>>>>>>>>>> When I installed version I hoped this behaiviour 
>>>>>>>>>>> would have
>>>>>>>>>>> been corrected, but now I could't even use the "Open..." 
>>>>>>>>>>> choise. It
>>>>>>>>>>> allways opens up an empty file with the name om the file 
>>>>>>>>>>> that should
>>>>>>>>>>> have opened. Same with version that I installed 
>>>>>>>>>>> today. For
>>>>>>>>>>> some reason I can open the default Splash.lyx that sits on 
>>>>>>>>>>> the "Recent
>>>>>>>>>>> files"
>>>>>>>>>>> I have backupped my Preferenses file and started up an 
>>>>>>>>>>> default version
>>>>>>>>>>> of LyX but the same behaviour continues. What could be the 
>>>>>>>>>>> reason for
>>>>>>>>>>> this? Have anyone had similar problems?
>>>>>>>>>> If you can open LyX from a terminal, with argument "-dbg 
>>>>>>>>>> files", you
>>>>>>>>>> might get more information. You can also  do this by opening the
>>>>>>>>>> messages pane (View> Messages Pane) and activating "files" debug
>>>>>>>>>> messages. (Go to Settings on the pane, click "Selected" then 
>>>>>>>>>> choose
>>>>>>>>>> "files").
>>>>>>>>>> I would guess there is something wrong with the path that LyX is
>>>>>>>>>> getting.
>>>>>>>>>> Riki
>>>>>>>>> Ok, thanks! I did that but the log shows nothing unusual. But the
>>>>>>>>> problem seems related only to files that reside in Dropbox 
>>>>>>>>> folders.
>>>>>>>>> Lyx opens the files directly but does not download the 
>>>>>>>>> contents from
>>>>>>>>> the Dropbox cloud. If i open a folder in the Dropbox app and
>>>>>>>>> doubleclick on a LyX-file it opens correctly in LyX. It used 
>>>>>>>>> to work
>>>>>>>>> without hazzle from the LyX-menus before. Maybe it is a 
>>>>>>>>> Dropbox problem.
>>>>>>>> It sounds like it. I assume there must be some notification to the
>>>>>>>> Dropbox app that a file has been accessed. LyX wouldn't provide 
>>>>>>>> that,
>>>>>>>> but the OS, or possibly Qt in this case, might.
>>>>>>>> Riki
>>>>>> It may be specific to the Mac OS. I just uploaded (via web browser) a
>>>>>> .lyx file to a shared Dropbox folder owned by a coauthor, then 
>>>>>> opened it
>>>>>> in LyX via the file menu with no problems. This was on Linux Mint.
>>>>>> Paul
>>>>> What is the setting of \use_native_filedialog (possibly in 
>>>>> preferences? : it defaults to
>>>>> 'true' if not set)
>>>> On a Mac it’s shipped w/o any assignment. So it should be true.
>>>> Stephan
>>>> -- 
>>>> lyx-users mailing list
>>>> lyx-users at <mailto:lyx-users at>
>>> Hi Niklas,
>>> Have you activated the new new functionality in Dropbox that keeps 
>>> files in the cloud but only keeping a file handle in the DB folder. 
>>> You could be trying to open such a file and DB seems not to be able 
>>> to detect the request to the file but Lyx and download it before 
>>> opening it.
>> Hello!
>> Yes, that seems to be the problem. I started using the Dropbox cloud 
>> and file handle option in March this year and as I remember it worked 
>> OK with LyX until version But I also have new versions of 
>> the Mac OS and Dropbox so it is quite hard to determine the ultimate 
>> reason. But other files (jpg, .odt, and even .docx) open fine using 
>> Open in menu options and doubleclicking them in Finder or other 
>> filehandling programs. Just the LyX-files needs to be opened from a 
>> folder opened in the dropbox app. I also tried the 
>> \use_native_filedialog false/true option in Preferences but it makes 
>> no difference in my case.
>> Best regards
>> Niklas
>> -- 
>> lyx-users mailing list
>> lyx-users at <mailto:lyx-users at>
> Prof. Murat Yildizoglu
> Advisor to the Minister of Education, Youth and Sports of Cambodia
> Expertise France
> On temporary leave from
> University of Bordeaux

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list