Xubuntu 20.04: Qt Library

Dr Eberhard W Lisse el at lisse.na
Sat Dec 12 22:47:28 UTC 2020


I would try the PPA on a testsystem before changing in production, in your situation. That would then update with the usual “apt update”.

I like bleeding edge, tip of the spear, crack of my ass, to quote... but use homebrew on the mac so as to not have to do anything manually which is difficult to keep track...

el

—
Sent from Dr Lisse’s iPhone
On 12 Dec 2020, 23:47 +0200, Richard Kimberly Heck <rikiheck at lyx.org>, wrote:
> On 12/12/20 4:18 PM, John White wrote:
> > This sounds like an excellent way to keep lyx up to date, but I am clueless
> > about alternative repositories. If they require github, I'm not interested.
> > Lyx 2.3.2 ships with Debian Buster and it works fine for my purposes. I have
> > learned that adding software versions not in the Buster repository sometimes
> > causes problems. So I will probably keep using 2.3.2 until next summer or so
> > when, I expect, Debian should come out with a new version.
>
> It's really quite easy to build LyX yourself. You don't need git (let
> alone github). You can just download the source that we release. Then
> it's the usual method:
>
> # tar -zxvf lyx-2.3.6.tar.gz
> # cd lyx-2.3.6
> # ./configure
>
> Add --enable-qt5 there if you want to use qt5
>
> # make
> # sudo make install
>
> To get the dependencies needed for the build, you should be able to do:
>
> # sudo apt-get build-deps lyx
>
> There's also a PPA for Ubuntu. I don't know if it works with Debian.
>
> Riki
>
>
> >
> > Best,
> >
> > John
> >
> > On Saturday, December 12, 2020 7:42:23 AM PST Dr Eberhard W Lisse wrote:
> > > Hartmut,
> > >
> > > would a better approach not be an alternative repository from which the
> > > package manager then can install the latest DEB?
> > >
> > > el
> > >
> > > On 2020-12-12 12:47 , Hartmut Haase wrote:
> > > > Hi Richard,
> > > >
> > > > > I'm a little puzzled why you would need that. LyX uses Qt, yes, but
> > > > if I install LyX from the distribution it is about 9 month older than
> > > > the last release. Because this one does not have binaries for all
> > > > distributions, I use to compile myself. Therefore I need the Qt library
> > > > files.
> > > > The error message is
> > > > checking for Qt library name... failed
> > > > configure: error: cannot compile a simple Qt executable. Check you have
> > > > the
> >
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lyx.org/pipermail/lyx-users/attachments/20201213/af59ee88/attachment-0001.html>


More information about the lyx-users mailing list