Xubuntu 20.04: Qt Library

Richard Kimberly Heck rikiheck at lyx.org
Sat Dec 12 17:05:57 UTC 2020


On 12/12/20 5:47 AM, Hartmut Haase wrote:
> Hi Richard,
>> I'm a little puzzled why you would need that. LyX uses Qt, yes, but
> if I install LyX from the distribution it is about 9 month older than
> the last release. Because this one does not have binaries for all
> distributions, I use to compile myself. Therefore I need the Qt library
> files.
> The error message is
> checking for Qt library name... failed
> configure: error: cannot compile a simple Qt executable. Check you
> have the

As Kornel said, you may be missing the Qt header files. So you need to
install something like qt-devel. Note that, by default, the 2.3.x series
uses Qt 4 (this will change with 2.4.0, though Qt will still be usable).
So, even if you have the Qt 5 devel packages, that may fail, unless you
configure with --enable-qt5. You can also install the Qt4 devel packages
and not use that flag.

I believe you should be able to do "sudo apt-get build-dep lyx" to
install the build dependencies. I don't know whether those would be for
Qt 4 or Qt 5, so you may have to experiment.

Riki




More information about the lyx-users mailing list