Lyx-2.3.6 build failure [FIXED]

Rich Shepard rshepard at appl-ecosys.com
Tue Dec 1 14:01:56 UTC 2020


On Tue, 1 Dec 2020, Jean-Marc Lasgouttes wrote:

> Wild guess:
>
> moc_FileMonitor.cpp:13:2: error: #error "This file was generated using the 
> moc from 4.8.7. It"
> #error "This file was generated using the moc from 4.8.7. It"
>  ^
> The "moc" binary that you have in the path is from Qt 4.8.7, and the Qt 
> library is from a different version.

JMarc,

I had no idea what the 'moc' binary was.

Here are installed both qt-4.8.7-x86_64-4 and qt5-5.12.8-x86_64-1_SBo. I
thought some installed packages need version 4. Checking now with hoorex
(that reports what applications use a specified library) I learned there's
nothing installed dependent on qt4.

Removing that package lyx-2.3.6 is now building.

Thanks very much.

Stay well,

Rich


More information about the lyx-users mailing list