Beamer error on Lyx

Paul A. Rubin parubin73 at
Mon Aug 24 15:29:17 UTC 2020

On 8/24/20 11:14 AM, jcredberry at wrote:
> Yes Paul, it is. This is the same set of slides I use every year. No 
> changes except for homework. I have opened the file in my Mac with Lyx 
> 2.3.1-1 after saving it in Windows, and at compiling time the same 
> error appears:
> ! Package inputenc Error: Keyboard character used is undefined
> (inputenc) in inputencoding `latin9'.
> Again, this is a document that I have used for at least a couple of 
> years in its current state. Only minor changes have been made. When I 
> manually changed the encoding to UTF-8, it worked flawlessly. I tried 
> opening other Beamer files that I have not opened in Windows and they 
> even work without changing the encoding.
> I think something bad happened while working on my file in Windows 
> that has permanently damaged it. I hope this is not something that can 
> break down the workflow for the ones who work in different OS´s.
> Regards,
> Julio Rojas
> jcredberry at <mailto:jcredberry at>
> On Mon, Aug 24, 2020 at 10:04 AM Paul A. Rubin <parubin73 at 
> <mailto:parubin73 at>> wrote:
>     On 8/23/20 7:27 PM, jcredberry at
>     <mailto:jcredberry at> wrote:
>>     Dear all,
>>     Trying to open a Beamer presentation that I used for my lectures
>>     every year. After some adjustment for this year's lectures, the
>>     following error appears when compiling the document:
>>     ! Package inputenc Error: Keyboard character used is undefined
>>     (inputenc) in inputencoding `latin9'.
>>     This is a document that I usually work with on Ubuntu Linux, but
>>     that in this case, I opened in Windows 10.
>>     I changed default coding to UTF-8 instead of inputenc and another
>>     error appears. In this case, the small logo in the right corner
>>     is not recognized and as the filename is "uct_logo.png", at
>>     compilation time it says the file is not found and then a box
>>     with "uct_logo" appears, with the "l" in "logo" as a subscript.
>>     Is this problem a Windows or a Lyx related one? BTW, I am using
>>     TeXLive 2019 on this windows computer.
>>     Regards,
>>     Julio Rojas
>>     jcredberry at <mailto:jcredberry at>
>     Is the logo PNG file in the same directory as the LyX file? If
>     not, have you tried specifying the path to it?
>     Paul
>     -- 
>     lyx-users mailing list
>     lyx-users at <mailto:lyx-users at>
If by any chance you kept the original Mac version (did not overwrite it 
with the version saved on Windows), you could diff the two LyX files to 
find the offending character.

Other than having a different idea about what an end-of-line character 
should be, I don't recall Windows mucking up characters on its own. If 
you paste in something copied from, say, a PDF (where there are 
ligatures) or maybe type something like an accented letter while 
editing, maybe that could be the source of the problem?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list