no modules availables

Wolfgang Engelmann engelmann at
Sat Aug 15 07:36:32 UTC 2020

Am 14.08.20 um 19:34 schrieb Paul A. Rubin:
> On 8/14/20 11:28 AM, Jose Ramom Flores das Seixas wrote:
>> Hi:
>> I take a long time without using /LyX/, but my package manager has 
>> been updating lyx when new versions come out. Nowadays, I have 
>> installed version (OS: Ubuntu 18.04).
>> Today I tried to edit a file, with lyxformat 544, but /LyX/ tells me a 
>> module is missing. Looking at the module dialogue I found that no 
>> module is available.
>> I've checked that the standard module files are in 
>> /usr/share/lyx/layouts, and besides them I have some other modules in 
>> ~/.lyx/layouts.
>> When I run /LyX/ from a terminal I can notice the following error:
>> UnicodeDecodeError: 'utf8' codec can't decode byte 0xa9 in position 
>> 395: invalid start byte support/Systemcall.cpp (276): Systemcall: 
>> 'python -tt "/usr/share/lyx/" --binary-dir="/usr/bin/"' 
>> finished with exit code 1
>> LyX: Done!
>> Finally, when executing *Reconfigure*, an error dialog appears with 
>> the following message:
>> The system reconfiguration has failed.
>> Default textclass is used but LyX may
>> not be able to work properly.
>> Please reconfigure again if needed.
>> I've run *Reconfigure* several times, but the modules still don't 
>> appear.Any leads on what's not going well?
>> Cheers
>> Ramom
> It would be nice to know if the alleged non-UTF8 character is in 
> or in some file it is trying to read.
> I've attached from my system (Linux Mint 19.3). You might 
> start by comparing it to the one on your system (in /usr/share/lyx) 
> using diff, meld or whatever tool you prefer. If there is a discrepancy, 
> try reconfiguring using my copy.
> If there's no difference in the script files, I would suggest trying to 
> run the configuration script directly in a terminal (python -tt 
> "/usr/share/lyx/" --binary-dir="/usr/bin/"). If you get the 
> same error message, check ~/.lyx/configure.log to see if you can figure 
> out where the error occurred, and maybe post the log here.
> Paul
I have followed the discussion and proposals on "no modules available"
In my case I get:

  python /usr/share/lyx/
Traceback (most recent call last):
   File "/usr/share/lyx/", line 23, in <module>
     filemode = 'w')
   File "/usr/lib/python2.7/logging/", line 1554, in basicConfig
     hdlr = FileHandler(filename, mode)
   File "/usr/lib/python2.7/logging/", line 920, in __init__
     StreamHandler.__init__(self, self._open())
   File "/usr/lib/python2.7/logging/", line 950, in _open
     stream = open(self.baseFilename, self.mode)
IOError: [Errno 13] Permission denied: '/usr/share/lyx/configure.log'

wolfgang at Fuji:/usr/share/lyx$ lyx
Warning: Failed to produce 1 preview snippet(s)

is this, what one would expect if everything is ok?


More information about the lyx-users mailing list