no modules availables

José Abílio Matos jamatos at
Fri Aug 14 21:37:57 UTC 2020

On Friday, 14 August 2020 16.28.22 WEST Jose Ramom Flores das Seixas wrote:
> Hi:
> I take a long time without using LyX, but my package manager has been
> updating lyx when new versions come out. Nowadays, I have installed version
> (OS: Ubuntu 18.04).
> Today I tried to edit a file, with lyxformat 544, but LyX tells me a module
> is missing. Looking at the module dialogue I found that no module is
> available.
> I've checked that the standard module files are in /usr/share/lyx/layouts,
> and besides them I have some other modules in ~/.lyx/layouts.
> When I run LyX from a terminal I can notice the following error:
> UnicodeDecodeError: 'utf8' codec can't decode byte 0xa9 in position 395:
> invalid start byte support/Systemcall.cpp (276): Systemcall: 'python -tt
> "/usr/share/lyx/" --binary-dir="/usr/bin/"' finished with exit
> code 1
>  LyX: Done!

From experience this means that you have a old layout file or module that have 
an encoding that is not utf-8. In your case I assume that the culprit is 
either in latin1 or latin9 (the difference between those is the presence/
absence of the euro sign).

Also I thought that we had fixed all the remainder errors like this in

So my suggestion is to go to your personal lyx directory and check the 
encoding of file. By default in linux the location of the personal directory 
is ~/.lyx. You can see this in LyX using the menu: Help->About LyX->Version 
and see the User dir entry there.

Using the shell in my case I have:

$ cd ~/.lyx
$ file bind/*
bind/user.bind: ASCII text

My suggestion is to check the layouts directory that could be the likely 
source of the problem:

$ file layouts/*

What happens if from the command line you run directly:

$ python /usr/share/lyx/

That will tells where does the code fails and it will be easier to diagnose 
the issue.

> Finally, when executing Reconfigure, an error dialog appears with the
> following message:
> The system reconfiguration has failed.
> Default textclass is used but LyX may
> not be able to work properly.
> Please reconfigure again if needed.
> I've run Reconfigure several times, but the modules still don't appear. Any
> leads on what's not going well?
> Cheers
> Ramom

José Abílio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lyx-users mailing list