Patches for Python scripts

Enrico Forestieri forenr at lyx.org
Sat Jan 30 11:26:34 UTC 2021


On Sat, Jan 30, 2021 at 05:31:05AM +0100, Thibaut Cuvelier wrote:
> On Sat, 30 Jan 2021 at 02:31, Enrico Forestieri <forenr at lyx.org> wrote:
> >
> > So, it seems that you have to check also for the 32-bit version.
> >
> Indeed. Would the attached patch solve the problem? I first look for a
> 64-bit version before a 32-bit, just to favour newer things, but there is
> no other reason to do so.

The patch does not apply neither to current master nor to current stable
(most probably it depends on previous patches):

$ patch --dry-run -p1 < 0013-Configure-look-for-Java-in-the-registry-on-Windows.patch
checking file lib/configure.py
Hunk #1 FAILED at 330.
Hunk #2 succeeded at 403 (offset -14 lines).
Hunk #3 succeeded at 1923 (offset -94 lines).
1 out of 3 hunks FAILED

and I had to apply it manually. Before applying it, I took away java from
PATH and reconfigured:

...
checking for a java interpreter...
+checking for "java"...  no
...

Correctly, java was not found (it is found when it is in PATH).
Then I applied the patch an reconfigured again:

...
checking for a java interpreter...
+checking for "java"...  no
Traceback (most recent call last):
  File "C:\cygwin\win\python\lib\logging\__init__.py", line 870, in emit
    stream.write(ufs % msg)
LookupError: unknown encoding: cp65001
Logged from file configure.py, line 346
...

I have a native Windows version of Python 2.7 installed in
"C:\cygwin\win\python".

So, it seems there is a problem with Python 2.

-- 
Enrico


More information about the lyx-devel mailing list