Changers
Jean-Marc Lasgouttes
lasgouttes at lyx.org
Wed Nov 11 23:43:37 UTC 2020
Le 12/11/2020 à 00:33, Yuriy Skalko a écrit :
> Since LyX uses primarily camelCase names, I renamed it to changeNone()
> and make_change(ref, val) to changeRef(ref, val). Is it good enough?
I still prefer noChange() or nullChange() to changeNone(), but we would
have to ask a native English speaker.
Concerning changeRef, I would say that the fact that this is a reference
is an implementation detail. Maybe change(ref, val) is good enough, or
else changeVar(ref, val).
Sorry for the nitpicking, but since this Changer stuff is not intuitive
at first sight, it is nice to have clear names.
> Implementing make_change_if(cond, ref, val) will have no much value
> since current make_change(ref, val) is used directly in conditionals
> only in 2 places, all other uses are via functions (changeShape etc).
> And we cannot use them as arguments since they will be evaluated before
> calling make_change_if. Or we have to use macros.
You are right.
JMarc
More information about the lyx-devel
mailing list