<div dir="ltr"><div><br></div>I forgot to include lyx-users, here it goes the mail<br><div><div class="gmail_quote"><div dir="ltr" class="gmail_attr">---------- Forwarded message ---------<br>From: <b class="gmail_sendername" dir="auto">jorge hernando</b> <span dir="auto"><<a href="mailto:jorgea.hernando@gmail.com">jorgea.hernando@gmail.com</a>></span><br>Date: Wed, Nov 11, 2020 at 1:05 PM<br>Subject: Re: no accents with dead keys (SOLVED)<br>To: José Abílio Matos <<a href="mailto:jamatos@lyx.org">jamatos@lyx.org</a>><br></div><br><br><div dir="ltr"><div>Hi Jose</div><div><br></div><div> I searched old e-mails and I believe I can confirm it's a bug in qt5 that ts triggered by un unknown mechanism. The previous fedora version I had (the 29) had lyx 2.3.3 and qt5.11 and it worked perfectly. When I installed fedora 32 the deadkeys were effectively dead. However, with featherpad (a qt application) I had the same problem while with nedit (non a qt appl.) had all the dead keys in order. I also think that not all the installations have the same problem because if it all had it, there probably were a massive outcry: almost every language, except english, has accents. <br></div><div><br></div><div>Lastly, I have not the foggiest notion of what Input Methods are; please tell me if there is something I can do.</div><div><br></div><div>Regards <br></div><div><br></div><div>Jorge<br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Wed, Nov 11, 2020 at 12:15 PM José Abílio Matos <<a href="mailto:jamatos@lyx.org" target="_blank">jamatos@lyx.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">



<div><p style="margin:0px">Hi Jorge,</p>
<p style="margin:0px">  let us keep this discussion in the mailing list to help others that could have the same problem. :-)</p>
<br><p style="margin:0px">On Wednesday, November 11, 2020 1:20:37 PM WET jorge hernando wrote:</p>
<p style="margin:0px">> I use mate as a desktop.</p>
<br><p style="margin:0px">I use mainly kde, sometimes test in gnome, and although I have not mate installed but I can install it to see if I can reproduce the problem.</p>
<br><p style="margin:0px">> This is the first time I had problems with lyx, and I'm using it from the</p>
<p style="margin:0px">> very beginning, I think more than twenty years. The previous Fedora I had,</p>
<p style="margin:0px">> was  29, I don't remember the qt version but I remember that it worked</p>
<p style="margin:0px">> flawlessly. I'm sure that the bug is in the qt5 library, but I don't know</p>
<p style="margin:0px">> how to discover how it is triggered. Any suggestions?</p>
<br><p style="margin:0px">One of the first things to test is to see if this is a problem of lyx or if you see it in other qt5 based applications. Simple examples here are kate and kwrite but any other application based on qt5 is OK to test. Could you try please and see if the problem also happens there?</p>
<br><p style="margin:0px">My first guess would be that this is related with Input Methods:</p>
<p style="margin:0px"><a href="https://fedoraproject.org/wiki/I18N/InputMethods#Qt_IM_modules" target="_blank">https://fedoraproject.org/wiki/I18N/InputMethods#Qt_IM_modules</a> </p>
<br><p style="margin:0px">but only testing can we know. :-)</p>
<br><p style="margin:0px">> Regards</p>
<p style="margin:0px">> </p>
<p style="margin:0px">> Jorge</p>
<br><br><p style="margin:0px">-- </p>
<p style="margin:0px">José Abílio</p>
</div>
</blockquote></div>
</div></div></div>