<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style></head><body lang=EN-GB link=blue vlink="#954F72"><div class=WordSection1><p class=MsoNormal>Thankyou for the feedback but it just sounds like a dialogue between  Alexand and Jurgen. I am not sure but are you are referring to something within the software of  Lyx and therefore a bug. From what you are saying  its with a temp file that’s created during the conversion. So can you explain why this error is occurring now and not before. What do you suggest I do? Is it a bug that’s just appeared in the lyx I have installed and not generally  the case. So maybe you would suggest reinstalling  lyx 2.2 or the most recnt version. Grateful for you feedback</p><p class=MsoNormal>Regards</p><p class=MsoNormal>Mike</p><p class=MsoNormal>Useful if you could include me explicitly in your discussion.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Sent from <a href="https://go.microsoft.com/fwlink/?LinkId=550986">Mail</a> for Windows 10</p><p class=MsoNormal><o:p> </o:p></p><div style='mso-element:para-border-div;border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal style='border:none;padding:0cm'><b>From: </b><a href="mailto:lyx@jalsti.de">Alexander</a><br><b>Sent: </b>11 June 2020 11:59<br><b>To: </b><a href="mailto:lyx-users@lists.lyx.org">lyx-users@lists.lyx.org</a><br><b>Subject: </b>Re: Intermediate .tex file during 'Convert' differs from manualexport, causes problems</p></div><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Hi,</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>On Thu, 11 Jun 2020 12:30:19 +0200</p><p class=MsoNormal>Jean-Marc Lasgouttes <lasgouttes@lyx.org> wrote:</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>> Le 11/06/2020 à 12:28, Jürgen Spitzmüller a écrit :</p><p class=MsoNormal>> > Am Donnerstag, den 11.06.2020, 11:50 +0200 schrieb Alexander:  </p><p class=MsoNormal>> >> The intermediate .tex temp file created by LyX, during exporting to</p><p class=MsoNormal>> >> markdown, has the two lines</p><p class=MsoNormal>> >> --</p><p class=MsoNormal>> >> \begin{lstlisting}%</p><p class=MsoNormal>> >> [language=Python]</p><p class=MsoNormal>> >> --</p><p class=MsoNormal>> >> which in the final markdown file look like</p><p class=MsoNormal>> >> --</p><p class=MsoNormal>> >>      %</p><p class=MsoNormal>> >>      [language=Python]  </p><p class=MsoNormal>> > </p><p class=MsoNormal>> > Since this is perfectly valid LaTeX it strikes me a pandoc bug. I</p><p class=MsoNormal>> > suggest you file a report at https://github.com/jgm/pandoc/issues</p><p class=MsoNormal>> > </p><p class=MsoNormal>> > As for the export, you could add an intermediate script that</p><p class=MsoNormal>> > transfers</p><p class=MsoNormal>> > </p><p class=MsoNormal>> > }%</p><p class=MsoNormal>> > [</p><p class=MsoNormal>> > </p><p class=MsoNormal>> > to</p><p class=MsoNormal>> > </p><p class=MsoNormal>> > }[  </p><p class=MsoNormal>> </p><p class=MsoNormal>> Or maybe even remove traces of "%\n" ?</p><p class=MsoNormal>> </p><p class=MsoNormal>> JMarc</p><p class=MsoNormal>> </p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Thx for first suggestions, but isn't the real point, that LyX does</p><p class=MsoNormal>different .tex exports, depending on if it is an intermediate temporary</p><p class=MsoNormal>file, or manually done?</p><p class=MsoNormal>Shouldn't it be always the same, or shouldn't there at least be a</p><p class=MsoNormal>possibility to force the one or other option?</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Working around (IMHO) weird LyX behavior with additional scripts does</p><p class=MsoNormal>not really sound like the way to achieve the normal result, in my view…</p><p class=MsoNormal>If I only new at least which kind of .tex export mode LyX uses for</p><p class=MsoNormal>intermediate files, I would at least know where to try more tuning of</p><p class=MsoNormal>its behavior.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Alexander</p><p class=MsoNormal>-- </p><p class=MsoNormal>lyx-users mailing list</p><p class=MsoNormal>lyx-users@lists.lyx.org</p><p class=MsoNormal>http://lists.lyx.org/mailman/listinfo/lyx-users</p><p class=MsoNormal><o:p> </o:p></p></div></body></html>