texlive 2019 install

Wolfgang Engelmann engelmann at uni-tuebingen.de
Fri Oct 11 12:23:24 UTC 2019


Am 11.10.19 um 13:46 schrieb Wolfgang Engelmann:
> .....
>>> The biggest problems I face are that every year a new TexLive comes
>>> out, automatically, and causes my books not to compile. So once a year
>>> I spend six hours up close and personal with tlmgr, hunting down
>>> missing fonts and installing them, and maybe doing a few other things.
>>
>> >>> I have a TeX collection 2019 DVD and try to install texlive2019 
>> by using ./install-tl -gui from /media/wolfgang/TEXCOL2019 (using 
>> Linux Mint Tina)
>>
>> The gui opens but it tells that the standard list TEXDIR and 
>> TEXMFSYSVAR and TEXMFSYSCONFIG can not be reached or written to 
>> -please change
>>
>> I am lost here: Are these automatically set by the install-tl or do I 
>> have to create it manually? The TEXDIR  should be in 
>> /usr/local/texlive/2019 which does not exist yet. I can click on 
>> change but that just shows the assumed paths. In a how to quick 
>> install it says one does not need to be root, and its even 
>> discouraged, but creating it by hand (from a terminal) needs sudo.
>>
>> Can somebody give a hint (e.g. link to a reasonable site)?
>>
>> Wolfgang
>>
> incidently, this is what I get in the terminal:
>
> wolfgang at wolfgang-Mr-Whisper-Ultra-SSD-II:/media/wolfgang/TEXCOL2019/texlive$ 
> ./install-tl -gui
>
> Can't exec "wish": Datei oder Verzeichnis nicht gefunden at 
> ./install-tl line 89.
> Can't exec "wish8.6": Datei oder Verzeichnis nicht gefunden at 
> ./install-tl line 89.
> Can't exec "wish8.5": Datei oder Verzeichnis nicht gefunden at 
> ./install-tl line 89.
> Can't exec "tclkit": Datei oder Verzeichnis nicht gefunden at 
> ./install-tl line 89.
> Setting opt_gui to perltk instead at ./install-tl line 350.
> Loading ./tlpkg/texlive.tlpdb
> Installing TeX Live 2019 from: . (verified)
> Platform: x86_64-linux => 'GNU/Linux on x86_64'
> Distribution: inst (compressed)
>
> Directory for temporary files: /tmp/A7LU7v4wfl
>
> and this is in install-tl starting with line 82, line 89 is if (!exec ...
>
> # done scanning arguments
>   if ($want_tcl) {
>     unshift (@new_args, "--");
>     unshift (@new_args, 
> "$::installerdir/tlpkg/installer/install-tl-gui.tcl");
>     my @wishes = qw /wish wish8.6 wish8.5 tclkit/;
>     unshift @wishes, $ENV{'WISH'} if (defined $ENV{'WISH'});
>     foreach my $w (@wishes) {
>       if (!exec($w, @new_args)) {
>         next; # no return on successful exec
>       }
>     }
>     # no succesful exec of wish
>   } # else continue with main installer below
> }
> # end of wrapper block, start of the real installer
>
>
I think I am getting closer. I installed lyx by using in L Mint in the 
sources.list.d the lyx-devel-releases-bionic.list which puts the stuff 
in /usr/share/tex/texmf with /doc, /fonts, /tex/tex/latex/lyx ...

That is, tex latex .. are already installed.

I do get, however, with my lyx document errors for missing sty files and 
would actually prefer to use texlive and put it in /usr/local/texlive/2019

So I guess I have to remove all the tex stuff and install it from my DVD 
texlive anew. What about lyx 2.3.3 which I got the way described above. 
Should I reinstall it here or leave it in /usr/share... ?

Life (not only TeXLive) is complicated and becomes more so with age...

Wolfgang



More information about the lyx-users mailing list