Preparing for development

Yu Jin technikmagma at gmail.com
Tue Jan 7 14:22:16 UTC 2020


Thanks :),

In the mean while I have investigated the issue, where pdf files are not
displayed for me.
I have seen that there is a python script generated in a temporary folder,
which is then executed. It first should convert pdf6 to eps and then eps to
png. The first step seems to succeed but the second not. Then LyX can't
load the png file because it does not exist.
As far as I can tell it fails here:

os.system(r'magick ' + '"' + infile + '"' + ' ' + '"' + outfile + '"' + '')

I have tried to type this command manually into python command prompt (of
course after importing "os" and creating all the other variables, which are
created in the script, and making sure that the infile exists), but all I
get is <command "magick" not found>.

Strangely it works on the installed 2.3.3 version, which I downloaded from
lyx.org and installed, but it does not on both versions (master and
stable), which I have compiled on my PC. Even though the scripts are same.

What also just worked, I copied the LyX.exe which I compiled on my PC
(stable) into the bin folder of the installed LyX (moved the origional one
to a different place beforehand) and tried it out with that one, pdf file
was displayed so the python script succeeded.

Any idea what is going on there?


Eugene
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lyx.org/pipermail/lyx-devel/attachments/20200107/a04fa340/attachment.html>


More information about the lyx-devel mailing list