Four babel_auto-legacy tests failing

Guenter Milde milde at users.sf.net
Mon Dec 30 17:08:41 UTC 2019


On 2019-12-19, Guenter Milde wrote:
> On 2019-12-18, Jürgen Spitzmüller wrote:

>> Am Mittwoch, den 18.12.2019, 11:46 -0500 schrieb Scott Kostyshak:
>>> The following tests FAILED:
>>>         343 - export/export/latex/languages/supported-
>>> languages_babel_auto-legacy_dvi (Failed)
>>>         345 - export/export/latex/languages/supported-
>>> languages_babel_auto-legacy_pdf (Failed)
>>>         346 - export/export/latex/languages/supported-
>>> languages_babel_auto-legacy_pdf2 (Failed)
>>>         347 -
>>> UNRELIABLE.NONSTANDARD_export/export/latex/languages/supported-
>>> languages_babel_auto-legacy_pdf3 (Failed)

>>> Can anyone reproduce?

>> I can. Seems Macedonian is the culprit.

> It is a problem with Belarussian (redefining \cyrillictext to also set
> the langauge to belarussian) that is incompatible with Macedonian (in
> addition to Russian).

> I added a branch-wrapper so that you may choose between Belarussian or
> Macedonian/Russian examples.

I have to correct myself. It is indeed a conflict
Macedonian <-> Belarusian, Bulgarian, Mongolian, Ukrainian, Russian

* Macedonian works together with Serbian and Kazakh.

* Sometimes I also see a conflict between Bulgarian and Russian and
  sometimes it works :(

> Please retest.

The new file "cyrillic-languages-conflict" should allow interactive
testing with different branches activated. So we may hopefully narrow down
the reason for Kornel's different test result.

A happy New Year,

Günter




More information about the lyx-devel mailing list