2.4 alpha2 failing on windows 10

Thibaut Cuvelier tcuvelier at lyx.org
Thu Feb 11 21:34:38 UTC 2021


On Thu, 11 Feb 2021 at 22:09, Richard Kimberly Heck <rikiheck at lyx.org>
wrote:

> On 2/11/21 4:04 PM, José Abílio Matos wrote:
> > On Thursday, February 11, 2021 7:53:36 PM WET Thibaut Cuvelier wrote:
> >> I would guess it is os::find_python_binary. But it has not been touched
> in a
> >> long time.
> >>
> >> It's highly likely that it does. On Windows, the first thing this
> function
> >> checks is `py -3`, but I haven't seen any py binary in a long time
> >> (although I've been using the Anaconda Python distribution for quite
> some
> >> time).
> > Since we require python to run maybe it would make sense to add the
> > information that comes from os::find_python to "Help -> About LyX".
> >
> > What do you think? (this is meant to every one not just Thibaut) :-)
>
> I think that's a good idea. I can do it later tonight unless someone
> beats me to it.
>
> We need a couple other fixes to the dialog, too, anyway.
>

+1 for the idea too. It might also be good to show all the versions of
anything (not purely TeX-based) that LyX might use and that has been
discovered by configure.py. It might also be useful to indicate which
version was chosen, i.e. bundled or no (e.g., the bundled Python or Perl).
For TeX stuff, maybe Tools > TeX Information is enough? I frankly have no
idea…
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lyx.org/pipermail/lyx-devel/attachments/20210211/d0f8282a/attachment.html>


More information about the lyx-devel mailing list