2.4 alpha2 failing on windows 10

Yu Jin yu_jin at lyx.org
Thu Feb 11 21:01:47 UTC 2021


Am Do., 11. Feb. 2021 um 20:05 Uhr schrieb José Abílio Matos <
jamatos at lyx.org>:

> On Thursday, February 11, 2021 4:02:19 PM WET Yu Jin wrote:
> > Will be pointless imo, it's not the script's fault that python is not
> found.
> > The fault is to be searched in the part of code which adds the prefix
> path
> > to the environment, which part would that be? After all when installing,
> > the installer adds the prefix path to its environment too on runtime
> while
> > installing and then calls the script, it is successful then.
>
> Does Tools->Reconfigure works after adding the python path in the
> environment
> variable?
>
As written before, after adding, python is found, so the script actually
starts, but it does not find other binaries (ghostscript and imagemagick)
which are also in the path prefix.

>
> I expect it to work. If it works that means that the configure.py changes
> are
> not the culprit.
>
> Eugene, could it be some change in the windows installer between alpha 1
> and
> alpha 2?
>

There were no changes in the installer.

Again, imo the part which adds path prefix (see attachment) to the runtime
environment must be broken.
-- 
    Eugene
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lyx.org/pipermail/lyx-devel/attachments/20210211/324a0883/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: path prefix.png
Type: image/png
Size: 28217 bytes
Desc: not available
URL: <http://lists.lyx.org/pipermail/lyx-devel/attachments/20210211/324a0883/attachment-0001.png>


More information about the lyx-devel mailing list