DocBook to ePub

Pavel Sanda sanda at lyx.org
Fri Feb 5 10:59:56 UTC 2021


On Fri, Feb 05, 2021 at 12:14:45AM +0100, Thibaut Cuvelier wrote:
> > Java dependency is sad news. Is there some bug within xsltproc which we
> > can bump or ask devs to fix it so we don't need to stick with saxon in
> > long term? I looked at https://gitlab.gnome.org/GNOME/libxslt/
> > and the project seems to be reasonably alive (If I look on the correct
> > repo).
> >
> 
> That's the right repo, as far as I know. I submitted a bug report:
> https://gitlab.gnome.org/GNOME/libxslt/-/issues/49. I guess I would have to
> dig deeper into xsltproc to properly debug this???

Thanks, let's see how this evolves.

> > > It's open for comments :)!
> >
> > Small technical glitches
> > - we will need to bundle those files into our tarball so Makefile.am entries
> >   are missing. (I can help with this once in master.)
> >
> 
> Indeed, I would like some help on this :).

Please go on and commit, so we do not exchange this large patch, it seems generally
fine.

> > - I think Saxon & stylesheets belong to 3rdparty directory
> >
> 
> I only see compile-time dependencies in that folder, while both Saxon and
> the stylesheets are run-time dependencies. It's really like /lib/tex,
> actually.

Ok.

> > - we need to give instructions to packagers why we bundle the stylesheets
> > and libraries (lib/RELEASE-NOTES looks as a good candidate) and make clear
> > which versions are needed to work correctly.
> >
> 
> Saxon: either 6.5.4 or 6.5.5 (other versions are known not to work). For the
> stylesheets, at least 1.76.

Could you add section about necessary components for epub export into lib/RELEASE-NOTES?

I'll try to test the actual functionality once it lands in master.
Thanks :)
Pavel


More information about the lyx-devel mailing list