[LyX/2.3.x] Make build: amend 6f2cd26103d0 (allow more compilers)

Kornel Benko kornel at lyx.org
Sat Oct 26 13:01:29 UTC 2019


commit 24fae9f51bd2cdd6ce348d4f7a330527e37dde8a
Author: Jean-Marc Lasgouttes <lasgouttes at lyx.org>
Date:   Sat Jun 29 16:45:38 2019 +0200

    Make build: amend 6f2cd26103d0 (allow more compilers)
    
    Allow gcc 4.7 and 4.8, but use boost regex
    
    Allow visual studio 2015.
    
    (cherry picked from commit 1f90cd3b3f62c59c9a1f8ce3fb84ac163f52a9a2)
---
 CMakeLists.txt |   16 ++++++++++------
 1 files changed, 10 insertions(+), 6 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf862cc..2f80084 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -288,17 +288,21 @@ if(UNIX OR MINGW)
 	    #message(STATUS "dumpversion: error = ${_error}, result = ${_err}")
 	  endif()
 	  message(STATUS "Using GCC version ${GCC_VERSION}")
-	  if(GCC_VERSION VERSION_LESS 4.9)
-		  # Drop support for gcc versions prior to 4.9
-		  message(FATAL_ERROR "gcc >= 4.9 is required.")
+	  if(GCC_VERSION VERSION_LESS 4.6)
+		message(FATAL_ERROR "gcc >= 4.6 is required.")
+	  elseif(GCC_VERSION VERSION_LESS 4.9)
+		# <regex> in gcc is unusable in versions less than 4.9.0
+		# see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=53631
+		set(LYX_USE_STD_REGEX 0)
 	  else()
-		  set(LYX_USE_STD_REGEX 1)
+		set(LYX_USE_STD_REGEX 1)
 	  endif()
 	endif()
 	set(LYX_GCC11_MODE "${CXX11_FLAG}")
 else()
-		# Drop support for msvc versions prior to 1915
-		message(FATAL_ERROR "msvc >= 1915 is required.")
+	if(MSVC_VERSION LESS 1900)
+		# Drop support for msvc versions prior to 1900 (Visual Studio 2015)
+		message(FATAL_ERROR "Visual Studio >= 2015 is required.")
 	set(LYX_USE_STD_REGEX 0)
 #	if(MSVC10)
 #		set(LYX_USE_STD_REGEX 1) #TODO should we use it in ECMAScript mode?


More information about the lyx-cvs mailing list